„Die Abhängigkeit auf xbmc.python“ Fehler beheben

"Die Abhängigkeit auf xbmc.python" Fehler beheben

Die Fehlermeldung „Die Abhängigkeit auf xbmc.python konnte nicht aufgelöst werden“ taucht in der Regel auf, wenn ihr ein Kodi Addon installieren oder aktualisieren wollt. In diesem Artikel erklären wir euch, was die Fehlermeldung bedeutet und wie das Problem behoben wird.

Inhaltsverzeichnis

Was ist Python in Kodi?

Python ist die Programmiersprache von Kodi Erweiterungen. Alle Kodi Addons werden in Python geschrieben und entwickelt. Deshalb ist in jeder Version des Media Centers eine Python Version fest installiert.

Da Python von Haus aus in jeder Kodi Installation vorhanden ist, binden Kodi Addons die Programmiersprache standardmäßig ein. So können die Entwickler bestimmte Module und Funktionen verwenden, ohne die gesamte Programmiersprache importieren zu müssen.

Jedes Kodi Addon verwendet Python, wodurch diese Programmiersprache eine der wichtigsten Abhängigkeiten in Kodi ist.

Was bedeutet die Fehlermeldung „Die Abhängigkeit auf xbmc.python konnte nicht aufgelöst werden“?

Wie bereits erwähnt, müssen alle Kodi Addons die Programmiersprache Python verwenden. Deshalb ist diese Abhängigkeit fest im Quellcode jeder Erweiterung hinterlegt.

Python wird regelmäßig aktualisiert und in neuen Versionen veröffentlicht. Die Entwickler von Kodi binden in jedem Update des Media Centers eine neue Version dieser Programmiersprache ein. Installiert ihr also eine neue Version von Kodi, habt ihr auch einen aktuellen Stand von Python in eurem System.

Verwenden Kodi Addons eine ältere Version von Python, ist dies kein Problem. Es wird schlicht die benötigte Version installiert, damit die entsprechende Erweiterung ordnungsgemäß funktioniert.

Die besagte Fehlermeldung „Die Abhängigkeit auf xbmc.python konnte nicht aufgelöst werden“ taucht jedoch auf, wenn folgender Fall eintritt:

Die benötigte Python Version eines Kodi Addons ist neuer als die eurer Kodi Installation.

Ist dies der Fall, taucht die Fehlermeldung auf. Der Fehler hat meistens noch eine Versionsnummer im Namen. Die komplette Meldung lautet dann: „Die Abhängigkeit auf xbmc.python in Version 2.7.13 konnte nicht aufgelöst werden“.

„Abhängigkeit auf xbmc.python“ Fehler beheben

Die Lösung dieses Problems ist schlicht und ergreifend folgende: Installiert die neueste Version von Kodi oder führt ein Upgrade aus!

Das Problem ist nämlich, dass die Python Version von Kodi nicht durch ein Kodi Addon aktualisiert werden kann. Lediglich eine Abwärtskompatibilität wird unterstützt. Sobald aber ein Kodi Addon im Quellcode auf eine neue Version des Media Centers basiert, müsst ihr eure Kodi Installation updaten.

Zuletzt ist dieser Fehler vermehrt aufgetreten, da die Entwickler von Kodi Addons ihre Erweiterungen auf Version Kodi 18 Leia umgestellt haben.

Wir erklären euch auf unserer Website unter anderem Schritt für Schritt, wie ihr Kodi auf dem Amazon Fire TV oder auf Windows PCs installiert.

Fehler „Die Abhängigkeit auf xbmc.python in Version 3.0.0 konnte nicht aufgelöst werden“

Erscheint bei einem Kodi Addon die Fehlermeldung „Die Abhängigkeit auf xbmc.python in Version 3.0.0 konnte nicht aufgelöst werden“, verwendet ihr unter Kodi 18 Leia eine Erweiterung, die eigentlich für Kodi 19 Matrix entwickelt wurde.

Die neueste Version von Kodi setzt bekanntlich auf die Programmiersprache Python 3, während Kodi 18 und 17 Python 2 verwenden.

Derzeit raten wir allerdings davon ab, Kodi 19 Matrix zu verwenden, da bislang nur Testversionen für das neueste Update des Mediencenters veröffentlicht wurden. Kodi 19 läuft noch nicht stabil und ist für den täglichen Gebrauch nur bedingt geeignet.

4 Kommentare

  1. Die Fehlermeldung tritt bei mir in Kodi XBMC mit Mediathekview Plugin 0.64 auf; moniert wird die Abhängigkeit zu Python 3.0.0. Die obige Aussage des Autors ist damit eindeutig widerlegt und entbehrt jeglicher Professionalität, von Fachkenntnis ganz zu schweigen. Die Beschreibung der Fehlerbehebung ähnelt vielen Posts bei MS: „Führen Sie dringend sfc /scannow aus…blah, blah“!). Diese Erklärung kommt immer dann zum tragen, wenn der „Supporter“ keine Ahnung hat. Das Problem trat bei mir erst nach dem Update der Kodi-Version auf (vorher 18.7). Eine vernünftige Erklärung/Lösung konnte ich bis jetzt nicht finden.

    1. Version 0.64 funktioniert unter Kodi 18 einwandfrei. Version 0.65 hingegen ist für Kodi 19 Matrix gemacht und benötigt dementsprechend Paython 3.0.0. Wir vermuten: Du hast automatische Updates für das Addon aktiviert und Mediathekview versucht, auf die Version 0.65 zu aktualisieren, was natürlich fehlschlägt, da sie für Kodi 19 gemacht ist. Hoffentlich ist diese Fachkenntnis ausreichend. 😉

  2. Das witzige an dieser Fehlermeldung ist, das ich Kodi v19 Alpha1 Build 20200822 drauf habe und diese Fehlermeldung kommt.
    Ich habe somit doch die aller neuste kodi Version?!
    Warum bekomm ich bei fast jedem addon diese Fehlermeldung?

    Also kann die aussage doch hier nicht korrekt sein, das es nur abwärtskompatible ist.
    Fehlermeldung wie oben genannt mit „2.7.13

    1. Kodi 19 verwendet ausschließlich Python 3. So gut wie alle Kodi Addons setzen noch auf Python 2 und müssen erst umprogrammiert werden, damit sie auch mit Kodi 19 funktionieren. Deshalb erscheint auch die Fehlermeldung bei dir: Python 2 ist in Kodi 19 schlicht nicht vorhanden.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.